<!DOCTYPE html PUBLIC "-//W3C//DTD HTML+RDFa 1.1//EN">
<html lang="en" dir="ltr" version="HTML+RDFa 1.1"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="author" content="Kyle Stevens" />
<meta property="news_keywords" content="sports, high school,girls basketball, Lake City Tigers" />
<meta property="description" content="LAKE CITY – In what may go down as the most unlikely comeback of the 2016-17 season, Lake City put Lewiston-Altura back on the bus Thursday with a 52-point..." />
<meta property="keywords" content="sports, high school,girls basketball, Lake City Tigers" />
<meta property="article:tag" content="sports, high school,girls basketball, Lake City Tigers" />
<meta property="article:publisher" content="https://www.facebook.com/redwingrepublicaneagle" />
<meta property="article:published_time" content="2016-12-22T21:58:23-06:00" />
<meta property="image:alt" content="Lake City&#039;s Allison Kubista launches a 3-pointer during the first half of the Tigers&#039; 76-56 victory over Lewiston-Altura on Thursday at Lincoln High School in Lake City. Kubista hit five 3-pointers in the game, and finished with 23 points in the win. (Republican Eagle photo by Kyle Stevens)" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:title" content="Girls Basketball: Lake City mounts wild comeback for win over..." />
<meta property="twitter:url" content="http://www.republican-eagle.com/sports/high-school/4185633-girls-basketball-lake-city-mounts-wild-comeback-win-over-l" />
<meta property="article:modified_time" content="2016-12-22T21:58:23-06:00" />
<meta property="image:title" content="Allison Kubista" />
<meta property="twitter:description" content="LAKE CITY – In what may go down as the most unlikely comeback of the 2016-17 season, Lake City put Lewiston-Altura back on the bus Thursday with a 52-point second half that erased a 16-point deficit at halftime.The Tigers, missing star captain Daynalyn Jostock for most of the game, finished off the..." />
<meta property="twitter:image" content="http://www.republican-eagle.com/sites/default/files/styles/16x9_430/public/field/image/Allison%20Kubista.jpg?itok=o9TaO44L" />
<meta property="og:url" content="http://www.republican-eagle.com/sports/high-school/4185633-girls-basketball-lake-city-mounts-wild-comeback-win-over-l" />
<meta property="og:image" content="http://www.republican-eagle.com/sites/default/files/styles/square_300/public/field/image/Allison%20Kubista.jpg?itok=32sF6U0L" />
<meta property="fb:app_id" content="243322109167890" />
<meta property="og:image:width" content="300" />
<meta property="og:description" content="LAKE CITY – In what may go down as the most unlikely comeback of the 2016-17 season, Lake City put Lewiston-Altura back on the bus Thursday with a 52-point second half that erased a 16-point deficit at halftime.The Tigers, missing star captain Daynalyn Jostock for most of the game, finished off the..." />
<meta property="og:image:height" content="300" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Girls Basketball: Lake City mounts wild comeback for win over..." />
<link rel="apple-touch-icon" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/images/touch-icon.png" type="image/png" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<link rel="shortcut icon" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/favicon.ico" type="image/x-icon" />
<link rel="shortlink" href="/node/4185633" />
<link rel="amphtml" href="http://www.republican-eagle.com/sports/high-school/4185633-girls-basketball-lake-city-mounts-wild-comeback-win-over-l?amp" />
<link rel="canonical" href="/sports/high-school/4185633-girls-basketball-lake-city-mounts-wild-comeback-win-over-l" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
    <title>Girls Basketball: Lake City mounts wild comeback for win over L-A | Republican Eagle</title>
    <link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_drAaZvIujzE0WQHPZOt8-T119XbC59ClvGgsZR7SC8M.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_n1pCl2MA43tzliKvK4qXdpArepfCRU6u4sc5BywLwKU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/css/article-slider.css?oii1q8" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?oii1q8" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/css/global-no-mqs.css?oii1q8" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/css/global.css?oii1q8" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_i9vAYWtv6IzHqwhy80-mNt0nMbj6ItfIIfYo9XNSP4I.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_27W8u-HbankbPYe4D1Wd0wx_MB32l4m4HZYxyDhiieo.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-20', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var site_latitude = 44.56607; var site_longitude = -92.53695629999999;
//--><!]]>
</script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_752FeqKSN604umEFuGAnMRu2ta4ygs-_XDosotFQdgo.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/modules/custom/fcc_weather/scripts/min/fcc_weather_map_control.min.js?oii1q8"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_6LNmYXbJFrF_7W14muxt2N3zanu-C3tyGNx5A7k4lQ8.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?oii1q8"></script>
<script type="text/javascript" src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?oii1q8"></script>
<script type="text/javascript" src="//forumcomm-d.openx.net/w/1.0/jstag?nc=7021-Republican-Eagle"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.districtm.ca/merge/all.forumcom.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

        var ybotq = ybotq || [];
        (function() {
        var js = document.createElement('script');
        js.src = '//cdn.yldbt.com/js/yieldbot.intent.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(js, node);
        })();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

        function ybWidth(){
          var w = window,
              d = document,
              e = d.documentElement,
              x = Math.max(e.scrollWidth,e.offsetWidth,e.clientWidth);
          return x;
        }
        ybotq.push(function () {
          if(ybWidth()>=481) {
            yieldbot.pub('be77');//desktop
            yieldbot.defineSlot('LB');
            yieldbot.defineSlot('MR', {sizes: [
                [300, 250],
                [300, 600]
            ]});
            yieldbot.defineSlot('MR_2', {sizes: [
                [300, 250],
                [300, 600]
            ]});
          } else {
            yieldbot.pub('061f');//mobile
            yieldbot.defineSlot('MLB');
            yieldbot.defineSlot('mobrec');
          }
          yieldbot.enableAsync();
          yieldbot.go();
        });
//--><!]]>
</script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://a.postrelease.com/serve/load.js?async=true"></script>
<script type="text/javascript" src="https://cdn.connatix.com/min/connatix.renderer.destination.min.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4185633 node-type-article domain-www-republican-eagle-com context-sports"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <li class="last">
            <a href="/register" title="Register">Register</a>
          </li>
        </ul>
            <div id='out-of-page-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('out-of-page-ad');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class="menu"><li class="first leaf"><a href="http://www.carshq.com" title="">CarsHQ</a></li>
<li class="leaf"><a href="http://www.jobshq.com" title="">JobsHQ</a></li>
<li class="leaf"><a href="http://www.homeshq.com" title="">HomesHQ</a></li>
<li class="leaf"><a href="http://www.apartmentshq.com" title="">ApartmentsHQ</a></li>
<li class="leaf"><a href="/classifieds" title="">Classifieds</a></li>
<li class="last leaf"><a href="/marketplace_offers" title="">Marketplace</a></li>
</ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="Republican Eagle"><img src="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/logo.png" alt="Republican Eagle" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">Republican Eagle</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/sports/high-school/4185633-girls-basketball-lake-city-mounts-wild-comeback-win-over-l" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/4185007-minnesota-roundup-state-patrol-releases-video-drunk-semi-driver-fisherman-camera-finds'>Minnesota roundup: State patrol releases video of drunk semi driver; Fisherman with camera finds missing paddleboarder; 2 more state news stories</a></li><li><a href='/news/4184996-great-lakes-get-22-million-pounds-plastics-annually'>Great Lakes get 22 million pounds of plastics annually</a></li><li><a href='/news/4184303-closure-dates-vary-christmas-holiday'>Closure dates vary for Christmas holiday </a></li><li><a href='/news/4184377-minnesota-roundup-nw-minn-man-gets-37-years-sexually-assaulting-two-kids-jury-convicts'>Minnesota roundup: NW Minn. man gets 37 years for sexually assaulting two kids; Jury convicts &#039;mastermind&#039; of motel shootings; 7 more stories</a></li><li><a href='/news/crime-and-courts/4184376-suspects-sought-pierce-county-red-wing-woodbury-incidents'>Suspects sought in Pierce County, Red Wing, Woodbury incidents</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/tags/election-2016" target="_self">Election 2016</a></li><li><a href="/news/crime-and-courts" target="_self">crime and courts</a></li><li><a href="/news/government" target="_self">government</a></li><li><a href="/news/education" target="_self">education</a></li><li><a href="/news/business" target="_self">business</a></li><li><a href="/news/region" target="_self">region</a></li><li><a href="/news/accidents" target="_self">accidents</a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/wingers/4185707-boys-basketball-byron-claws-back-beat-red-wing'>Boys Basketball: Byron claws back to beat Red Wing</a></li><li><a href='/sports/high-school/4185702-boys-basketball-lake-city-moves-6-0'>Boys Basketball: Lake City moves to 6-0</a></li><li><a href='/sports/high-school/4185698-boys-basketball-bombers-tripped-hayfield'>Boys Basketball: Bombers tripped up by Hayfield</a></li><li><a href='/sports/high-school/4185652-girls-basketball-wildcats-grab-non-conference-win'>Girls Basketball: Wildcats grab non-conference win</a></li><li><a href='/sports/high-school/4185633-girls-basketball-lake-city-mounts-wild-comeback-win-over-l'>Girls Basketball: Lake City mounts wild comeback for win over L-A</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/sports/high-school" target="_self">high school</a></li><li><a href="/sports/amateur" target="_self">amateur</a></li><li><a href="/sports/outdoors" target="_self">outdoors</a></li><li><a href="/sports/wingers" target="_self">wingers</a></li></ul></div></div></li><li class='leaf'><a href="/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/life/health/4183900-author-make-christmas-eve-stop-fair-trade-books'>Author to make Christmas Eve stop at Fair Trade Books</a></li><li><a href='/life/arts-and-entertainment/4180785-postponed-anne-reed-joan-griffith-performance-rescheduled'>Postponed: Anne Reed, Joan Griffith performance rescheduled for February</a></li><li><a href='/life/arts-and-entertainment/4180757-nutcracker-wishing-you-fairy-merry-christmas'>&#039;The Nutcracker&#039;: Wishing you a fairy, merry Christmas</a></li><li><a href='/life/arts-and-entertainment/4180719-christmas-mick-sterling-comedic-heartwarming'>&#039;At Christmas&#039; with Mick Sterling comedic, heartwarming</a></li><li><a href='/life/family/4179224-making-new-memories-red-wing-family-looks-forward-new-habitat-humanity-home'>&#039;Making new memories&#039;: Red Wing family looks forward to new Habitat for Humanity home</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/life/arts-and-entertainment" target="_self">arts and entertainment</a></li><li><a href="/life/food" target="_self">food</a></li><li><a href="/life/health" target="_self">health</a></li><li><a href="/life/religion" target="_self">religion</a></li><li><a href="/life/family" target="_self">family</a></li><li><a href="/life/events" target="_self">events</a></li></ul></div></div></li><li class='leaf'><a href="/notices" target="_self">notices</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/legals/4185387-planning-comm'>PLANNING COMM</a></li><li><a href='/legals/4185388-public-notice'>PUBLIC NOTICE</a></li><li><a href='/legals/4185386-25-pr-16-2931-luhmann'>25-PR-16-2931 LUHMANN</a></li><li><a href='/legals/4176109-summons-perry-knudsen'>Summons - Perry Knudsen</a></li><li><a href='/legals/4176107-state-vs-bradley-d-sonnentag-et-al-condemnation'>STATE vs. Bradley D. Sonnentag, et al, CONDEMNATION</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4183795-james-j'>James J. </a></li><li><a href='/obituaries/4183880-gary-kreye-60'>Gary A. Kreye, 60</a></li><li><a href='/obituaries/4183793-frances-callstrom-94'>Frances A. Callstrom, 94</a></li><li><a href='/obituaries/4183794-helen-j-jacobson-82'>Helen J. Jacobson, 82</a></li><li><a href='/obituaries/4183792-shelly-l-eichorn-58'>Shelly L. Eichorn, 58</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/4184330-letter-nonprofits-often-find-background-checks-impossible'>Letter: Nonprofits often find background checks impossible</a></li><li><a href='/opinion/4184297-editorial-thank-our-elected-officials'>Editorial: Thank our elected officials  </a></li><li><a href='/opinion/columns/4181551-klobuchar-creating-jobs-and-driving-innovation-rural-minnesota'>Klobuchar: Creating jobs and driving innovation in rural minnesota</a></li><li><a href='/opinion/editorials/4181546-editorial-ready-or-not-winter-driving-has-arrived'>Editorial: Ready or not ... winter driving has arrived</a></li><li><a href='/opinion/columns/4179289-viewpoint-minnesotas-swamp-could-use-draining'>Viewpoint: Minnesota&#039;s swamp could use draining</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/columns" target="_self">columns</a></li><li><a href="/opinion/letters" target="_self">letters</a></li><li><a href="/opinion/editorials" target="_self">editorials</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="/basic-page/3729449-magazine-rack" target="_self">Magazine Rack</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/sports/wingers/4185707-boys-basketball-byron-claws-back-beat-red-wing'>Boys Basketball: Byron claws back to beat Red Wing</a></li><li><a href='/sports/high-school/4185702-boys-basketball-lake-city-moves-6-0'>Boys Basketball: Lake City moves to 6-0</a></li><li><a href='/sports/high-school/4185698-boys-basketball-bombers-tripped-hayfield'>Boys Basketball: Bombers tripped up by Hayfield</a></li><li><a href='/sports/high-school/4185652-girls-basketball-wildcats-grab-non-conference-win'>Girls Basketball: Wildcats grab non-conference win</a></li><li><a href='/sports/high-school/4185633-girls-basketball-lake-city-mounts-wild-comeback-win-over-l'>Girls Basketball: Lake City mounts wild comeback for win over L-A</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="https://en.calameo.com/read/00073526136127b70bf45" target="_self">Real Estate Showcase</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/sports/wingers/4185707-boys-basketball-byron-claws-back-beat-red-wing'>Boys Basketball: Byron claws back to beat Red Wing</a></li><li><a href='/sports/high-school/4185702-boys-basketball-lake-city-moves-6-0'>Boys Basketball: Lake City moves to 6-0</a></li><li><a href='/sports/high-school/4185698-boys-basketball-bombers-tripped-hayfield'>Boys Basketball: Bombers tripped up by Hayfield</a></li><li><a href='/sports/high-school/4185652-girls-basketball-wildcats-grab-non-conference-win'>Girls Basketball: Wildcats grab non-conference win</a></li><li><a href='/sports/high-school/4185633-girls-basketball-lake-city-mounts-wild-comeback-win-over-l'>Girls Basketball: Lake City mounts wild comeback for win over L-A</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="http://local.republican-eagle.com/ads" target="_self">Print Ads</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/sports/wingers/4185707-boys-basketball-byron-claws-back-beat-red-wing'>Boys Basketball: Byron claws back to beat Red Wing</a></li><li><a href='/sports/high-school/4185702-boys-basketball-lake-city-moves-6-0'>Boys Basketball: Lake City moves to 6-0</a></li><li><a href='/sports/high-school/4185698-boys-basketball-bombers-tripped-hayfield'>Boys Basketball: Bombers tripped up by Hayfield</a></li><li><a href='/sports/high-school/4185652-girls-basketball-wildcats-grab-non-conference-win'>Girls Basketball: Wildcats grab non-conference win</a></li><li><a href='/sports/high-school/4185633-girls-basketball-lake-city-mounts-wild-comeback-win-over-l'>Girls Basketball: Lake City mounts wild comeback for win over L-A</a></li></ul></div></div></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="sports "> <meta itemprop='dateline' content="Red Wing,Minnesota 55066"> <meta itemprop='articleBody' content="&lt;p&gt;LAKE CITY – In what may go down as the most unlikely comeback of the 2016-17 season, Lake City put Lewiston-Altura back on the bus Thursday with a 52-point second half that erased a 16-point deficit at halftime.&lt;/p&gt;&lt;p&gt;The Tigers, missing star captain Daynalyn Jostock for most of the game, finished off the 76-56 victory by clearing the end of the bench after it looked like the Cardinals would be the ones to run away with the game.&lt;/p&gt;&lt;p&gt;“That first half, I thought I was going to have a heart attack,” said Lake City's first-year head coach Clay Ostad. “Daynalyn is a big piece of the offense. When she went down, that was a captain, a senior leader, a double-double, and it took the girls a little bit of time to get used to that. But the girls did a great job in the second half overcoming that. They picked up the slack, and they picked up the defense, especially the press. I'm glad to pull that one out.”&lt;/p&gt;&lt;p&gt;Jostock, who scored the first eight points of the game for the Tigers, was carried off the court with 9 minutes, 3 seconds left in the first half after a couple of players fell into her legs on a loose ball. Lake City trailed 22-17 at that point, and would score only seven more points in the first half.&lt;/p&gt;&lt;p&gt;The defense suffered some with Jostock's absence, but the offense was in complete disarray. Three of the seven points were from free throws, while L-A hit a couple of 3-pointers and scored eight of the final 10 points of the opening 18 minutes.&lt;/p&gt;&lt;p&gt;With the team and coaches in the locker room, Jostock remained on the bench at halftime. That scene is usually followed by the visitors having their way with the game. But the Tigers had six points in the first two minutes of the second half and, after a two-point interruption from the Cardinals, ran off 15 more to take the lead, 45-42.&lt;/p&gt;&lt;p&gt;Much of that spark came from Allison Kubista, who hit four 3-pointers in that stretch, and scored 20 of her 23 points in the second half. Ava Wallerich had back-to-back steals that finished in layups, and had seven points, all after halftime. And Julia Anderson's nine points all came late.&lt;/p&gt;&lt;p&gt;“At halftime, we just talked it out a little bit, and I put it on them,” Olstad said. “They decided to pick up their energy and they played their game. They were definitely flat in the first half. I was impressed at how they came out and decided not to quit and to erase the deficit and pull this out.”&lt;/p&gt;&lt;p&gt;L-A briefly jumped ahead 46-45, but Lake City was not going to derail once again. The Tigers hit a couple of baskets, and again fended off a couple of quick scores from the Cardinals. The closest L-A would get again was two points, with 9:56 to play. Two minutes later it was a 10-point game, and by the time the reserves came in, it was an 18-point spread.&lt;/p&gt;&lt;p&gt;“Ava coming off the bench had a heck of a second half. Deandra (Oelkers) played great, tough, hard-working basketball. Allison hit a few big shots, and Julia , she's always strong with the ball,” Olstad said. “All around, that was just a great effort, and finally all five girls rebounded at one time.”&lt;/p&gt;&lt;p&gt;Before the score got out of hand, Jostock did make an appearance. It was brief, but a welcome sight for teammates, coaches and fans.&lt;/p&gt;&lt;p&gt;“She told me she could go, so I gave it a try. I was nervous about that, I didn't really want to test anything, basketball is a long season. I wanted to protect her,” Olstad said.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="Girls Basketball: Lake City mounts wild comeback for win over L-A"> <meta itemprop='author' content="Kyle Stevens"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2016-12-22T21:58:23"> <meta itemprop='dateModified' content="2016-12-22T21:58:23"> <link itemprop='mainEntityOfPage' content="node/4185633"> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="http://www.republican-eagle.com/sites/default/files/styles/square_300/public/field/image/Allison%20Kubista.jpg?itok=32sF6U0L"> <meta itemprop="width" content="2200"> <meta itemprop="height" content="2355"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Kyle Stevens"> </div> <div itemscope itemtype='http://schema.org/Person'> <meta itemprop='affiliation' content="Republican Eagle"</span> <meta itemprop="name" content="Kyle Stevens"> <meta itemprop="homeLocation" content="Red Wing"> <div itemprop='contactPoint' itemscope itemtype='http://schema.org/ContactPoint'> <meta itemprop='faxNumber' content="651-388-3404"> <meta itemprop='contactType' content="customer support"> <meta itemprop='url' content="http://www.republican-eagle.com"> <meta itemprop='telephone' content="(651) 301-7879"> <meta itemprop='email' content="kstevens@republican-eagle.com"> </div> <meta itemprop='url' content="http://www.republican-eagle.com"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="Girls Basketball: Lake City mounts wild comeback for win over L-A "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="Red Wing"> <meta itemprop='addressRegion' content="Minnesota"> <meta itemprop='streetAddress' content="2760 North Service Drive / P.O. Box 15"> <meta itemprop='postalCode' content="55066"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
        });
        </script>
        </div><h1 class='node-title'>Girls Basketball: Lake City mounts wild comeback for win over L-A</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/kyle-stevens'>Kyle Stevens</a></span>
  <span class='node-byline-time'> Today  at 9:58 p.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-image-wrapper large article-slider'><button class='next'><img src='/sites/all/themes/fcc_basetheme/images/arrow-next.png'></button><button class='prev'><img src='/sites/all/themes/fcc_basetheme/images/arrow-back.png'></button><div class='individual-slide individual-slide-1' style='position: relative;'><img class='node-image large' src='http://www.republican-eagle.com/sites/default/files/styles/16x9_620/public/field/image/Allison%20Kubista.jpg?itok=HEHs3P9p' data-featherlight='http://www.republican-eagle.com/sites/default/files/styles/full_1000/public/field/image/Allison%20Kubista.jpg?itok=gNcUgEub'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Lake City&#039;s Allison Kubista launches a 3-pointer during the first half of the Tigers&#039; 76-56 victory over Lewiston-Altura on Thursday at Lincoln High School in Lake City. Kubista hit five 3-pointers in the game, and finished with 23 points in the win. (Republican Eagle photo by Kyle Stevens)</span><span class='slide-number'>1 / 3</span></div><div class='individual-slide individual-slide-2' style='position: relative;'><img class='node-image large' src='http://www.republican-eagle.com/sites/default/files/styles/16x9_620/public/field/image/Laura%20Heitman_0.jpg?itok=Fi5qWqXA' data-featherlight='http://www.republican-eagle.com/sites/default/files/styles/full_1000/public/field/image/Laura%20Heitman_0.jpg?itok=MtcrzIKD'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Lake City&#039;s Laura Heitman drives by Allison Averbeck (33) during the first half of the Tigers&#039; 76-56 victory over Lewiston-Altura on Thursday at Lincoln High School in Lake City. Heitman had 16 points in the win. (Republican Eagle photo by Kyle Stevens)</span><span class='slide-number'>2 / 3</span></div><div class='individual-slide individual-slide-3' style='position: relative;'><img class='node-image large' src='http://www.republican-eagle.com/sites/default/files/styles/16x9_620/public/field/image/Daynalyn%20Jostock_2.jpg?itok=itXO7QrU' data-featherlight='http://www.republican-eagle.com/sites/default/files/styles/full_1000/public/field/image/Daynalyn%20Jostock_2.jpg?itok=9FLi_vie'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Lake City&#039;s Daylnalyn Jostock , left, blocks the shot of Madison Mundt during the first half of the Tigers&#039; 76-56 victory over Lewiston-Altura on Thursday at Lincoln High School in Lake City. Jostock left the game with an injury, but returned. The Tiger senior finished with 10 points in the win. (Republican Eagle photo by Kyle Stevens)</span><span class='slide-number'>3 / 3</span></div></div><div class='node-body'><p>LAKE CITY – In what may go down as the most unlikely comeback of the 2016-17 season, Lake City put Lewiston-Altura back on the bus Thursday with a 52-point second half that erased a 16-point deficit at halftime.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
        });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_3tsbe7spkzmbtnshic4avgk3fe' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>The Tigers, missing star captain Daynalyn Jostock for most of the game, finished off the 76-56 victory by clearing the end of the bench after it looked like the Cardinals would be the ones to run away with the game.</p><p>“That first half, I thought I was going to have a heart attack,” said Lake City's first-year head coach Clay Ostad. “Daynalyn is a big piece of the offense. When she went down, that was a captain, a senior leader, a double-double, and it took the girls a little bit of time to get used to that. But the girls did a great job in the second half overcoming that. They picked up the slack, and they picked up the defense, especially the press. I'm glad to pull that one out.”</p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>Jostock, who scored the first eight points of the game for the Tigers, was carried off the court with 9 minutes, 3 seconds left in the first half after a couple of players fell into her legs on a loose ball. Lake City trailed 22-17 at that point, and would score only seven more points in the first half.</p><p>The defense suffered some with Jostock's absence, but the offense was in complete disarray. Three of the seven points were from free throws, while L-A hit a couple of 3-pointers and scored eight of the final 10 points of the opening 18 minutes.</p><p>With the team and coaches in the locker room, Jostock remained on the bench at halftime. That scene is usually followed by the visitors having their way with the game. But the Tigers had six points in the first two minutes of the second half and, after a two-point interruption from the Cardinals, ran off 15 more to take the lead, 45-42.</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>Much of that spark came from Allison Kubista, who hit four 3-pointers in that stretch, and scored 20 of her 23 points in the second half. Ava Wallerich had back-to-back steals that finished in layups, and had seven points, all after halftime. And Julia Anderson's nine points all came late.</p><p>“At halftime, we just talked it out a little bit, and I put it on them,” Olstad said. “They decided to pick up their energy and they played their game. They were definitely flat in the first half. I was impressed at how they came out and decided not to quit and to erase the deficit and pull this out.”</p><div id='jobsHQ-hotjobs-single-2' class='jobsHQ-hotjobs-single'></div><p>L-A briefly jumped ahead 46-45, but Lake City was not going to derail once again. The Tigers hit a couple of baskets, and again fended off a couple of quick scores from the Cardinals. The closest L-A would get again was two points, with 9:56 to play. Two minutes later it was a 10-point game, and by the time the reserves came in, it was an 18-point spread.</p><p>“Ava coming off the bench had a heck of a second half. Deandra (Oelkers) played great, tough, hard-working basketball. Allison hit a few big shots, and Julia , she's always strong with the ball,” Olstad said. “All around, that was just a great effort, and finally all five girls rebounded at one time.”</p><p>Before the score got out of hand, Jostock did make an appearance. It was brief, but a welcome sight for teammates, coaches and fans.</p><p>“She told me she could go, so I gave it a try. I was nervous about that, I didn't really want to test anything, basketball is a long season. I wanted to protect her,” Olstad said.</p></div></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('third-mobile-ad');
          });
        });
        </script>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='http://www.republican-eagle.com/taxonomy/term/21'>sports</a><a class='topic category' href='http://www.republican-eagle.com/taxonomy/term/26905'>high school</a><a class='topic tag' href='http://www.republican-eagle.com/taxonomy/term/14711'>girls basketball</a><a class='topic tag' href='http://www.republican-eagle.com/taxonomy/term/74216'>Lake City Tigers</a></div><div class='node-author-block clearfix'><a class='node-author-name' href='/users/kyle-stevens'>Kyle Stevens</a><img class='node-author-pic' src='http://www.republican-eagle.com/sites/default/files/styles/vert_175/public/pictures/picture-210243-1378244421.jpg?itok=BdCYa4U4'><div class='node-author-bio'><span>Kyle Stevens is a sports reporter for the Red Wing Republican Eagle. Previously, Kyle worked at the Owatonna People’s Press, as well as KWLM and KLFN in Willmar. You can contact Kyle by phone at&nbsp;(651) 301-7879, via e-mail at&nbsp;</span><a class="Xx" dir="ltr" href="mailto:kstevens@republican-eagle.com" rel="nofollow" target="_blank">kstevens@republican-eagle.com</a><span>, and follow him on Twitter @RE_KStevens.</span></div><div class='node-author-email'>
        <a href='/user/210243/contact'>
          <span itemprop='email'>kstevens@republican-eagle.com</span>
        </a>
        </div><div class='node-author-number'>(651) 301-7879</div></div><div id='ad-content-distribution'></div><div class='node-ad node-ad-mobile'>Advertisement<div id='marketplaceDeal_widget_mobile'></div></div><div id='fourth-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('fourth-mobile-ad');
          });
        });
        </script>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',12);
  ga('send', 'event', 'article', 'paragraphs', '12');
  ga('send', 'event', 'article', 'length', 'characters',3460);
  ga('send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',6974);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',12);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '12');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',3460);
  ga('combinedSites.send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',6974);
</script>    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad odd block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class='node-ad node-ad-desktop'><div id='marketplaceDeal_widget' class='nocontent'></div></div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest even block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
      <div class="select-homepage">
      <a class="active trending" href="/trending">Trending</a>
    </div>
    <div class="space-eater-section fcc-trending">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/crime-and-courts/4184376-suspects-sought-pierce-county-red-wing-woodbury-incidents"><span class="number">1. </span>Suspects sought in Pierce County, Red Wing, Woodbury incidents</a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/obituaries/4183880-gary-kreye-60"><span class="number">2. </span>Gary A. Kreye, 60</a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/sports/high-school/4185556-boys-basketball-goodhues-roll-continues"><span class="number">3. </span>Boys Basketball: Goodhue&#039;s roll continues</a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/sports/high-school/4185652-girls-basketball-wildcats-grab-non-conference-win"><span class="number">4. </span>Girls Basketball: Wildcats grab non-conference win</a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/news/4185007-minnesota-roundup-state-patrol-releases-video-drunk-semi-driver-fisherman-camera-finds"><span class="number">5. </span>Minnesota roundup: State patrol releases video of drunk semi driver; Fisherman with camera finds missing paddleboarder; 2 more state news stories</a></div>
      </div>
        <a class="more" href="/trending">more <span class="arrow">〉</span></a>
</div>
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/sports/wingers/4185707-boys-basketball-byron-claws-back-beat-red-wing">Boys Basketball: Byron claws back to beat Red Wing<span class='latest-date'>21 min ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/sports/high-school/4185702-boys-basketball-lake-city-moves-6-0">Boys Basketball: Lake City moves to 6-0<span class='latest-date'>28 min ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/sports/high-school/4185698-boys-basketball-bombers-tripped-hayfield">Boys Basketball: Bombers tripped up by Hayfield<span class='latest-date'>32 min ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/sports/high-school/4185652-girls-basketball-wildcats-grab-non-conference-win">Girls Basketball: Wildcats grab non-conference win<span class='latest-date'>1 hour ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/sports/high-school/4185633-girls-basketball-lake-city-mounts-wild-comeback-win-over-l">Girls Basketball: Lake City mounts wild comeback for win over L-A<span class='latest-date'>1 hour ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-fcc-advertising block-wishabi-article block-fcc-advertising-wishabi-article odd block-without-title" id="block-fcc-advertising-wishabi-article">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Wishabi Circular widget on Article -->
          <div id='circularhub_module_6251' class='nocontent'></div>
          <script src='http://api.flyertown.ca/6251/2abb546c0a8af6a5/circularhub_module.js'></script>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget even block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><section class="block block-views block-classified-featured-block block-views-classified-featured-block odd" id="block-views-classified-featured-block">
  <div class="block-inner clearfix">
              <h2 class="block-title">Top Ads</h2>
            
    <div class="content clearfix">
      <div class="view view-classified-featured view-id-classified_featured view-display-id-block view-dom-id-34485761edddb41e1744360beb558f21">
    
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2423655">
      Mini & Toy   Australian Shepherd Puppies For Sale   Mini Aussies- Red Tri Male, 2-Red Tri Females  Black Tri & Red Merle Female; 1-Blue Merle    </a>
    </span>
  </p>
  </div>
  </div>
  <div class="views-row views-row-2 views-row-even top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2418542">
      COMMERCIAL SPACE available in new building with nice convenient location!  <br>Commercial Park off Hwy C., Somerset, WI.  <br> <br>    </a>
    </span>
  </p>
  </div>
  </div>
  <div class="views-row views-row-3 views-row-odd top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2418509">
      Tim Alms Photography <br>Great Gift Idea for home or office!  <br>Many photos and sizes to choose from, framed or unframed.  <br>    </a>
    </span>
  </p>
  </div>
  </div>
  <div class="views-row views-row-4 views-row-even views-row-last top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2418503">
      WE BUY AND TOW Unwanted and Wrecked Vehicles.   <br>MN Licensed Dealer.   <br>Call for Quote: 651-322-1800   <br>www.upullrparts.com    </a>
    </span>
  </p>
  </div>
  </div>
    </div>
              <span class="class-11px"><a href="/classifieds/featured">View all top ads &raquo;</a></span>
</div>    </div>
  </div>
</section><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget even block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-homeshq-widget block-boxes-homeshq-widget odd block-without-title" id="block-boxes-homeshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-homeshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="homes_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget even block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('bottom-leaderboard-ad');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='https://newspaper.forumcomm.com/cgi-bin/cmo_cmo.sh/custservice/web/login2.html?siteid=RRE' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/republican-eagle" title="">Subscribe to the Paper</a></li>      <li><a href="http://www.newspaperprints.com" title="">Buy Newspaper Prints</a></li>
      <li><a href="http://www.rivertownmultimedia.com">Advertise with us</a></li>    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="http://forumcomm.desk.com/" title="">Get Website Help</a></li>
      <li><a href="http://www.jobshq.com/employers/page/profile/employer/34/" title="">Work With Us</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="http://www.jobshq.com" target="_blank" title="">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="">CarsHQ</a></li>
      <li><a href="http://www.homeshq.com" target="_blank" title="">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="">Northland Outdoors</a></li>
      <li><a href="http://www.agweek.com" target="_blank" title="">Agweek</a></li>
      <li><a href="http://impact.areavoices.com" target="_blank" title="">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://www.twitter.com/republicaneagle" title="Find us on Twitter"><img alt="Find us on Twitter" src="/sites/all/themes/fcc_basetheme/images/icons/twitter-social.png" /> Twitter</a></li><li><a href="https://www.facebook.com/redwingrepublicaneagle" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li><li><a href="https://plus.google.com/102646955521009741833/" title="Find us on Google+" rel="publisher"><img alt="Find us on Google+" src="/sites/all/themes/fcc_basetheme/images/icons/google-social.png" /> Google+</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; Republican Eagle</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; Republican Eagle</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">2760 North Service Drive / P.O. Box 15</div>
      <span class="locality">Red Wing</span>, 
      <span class="region">Minnesota</span> 
      <span class="postal-code">55066</span>
    </div>

    Call us at <div class="tel">651-388-8235</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div><a rel="nofollow" href="http://www.fccnn.com/newspaper.php"><!-- randomness --></a></div>  </div>
</div><script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/modules/custom/fcc_advertising/adblock/min/adblock.min.js?oii1q8"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.ajax({url:'http://itracking.fccinteractive.com/tracking/drupalcms/insert_impressions.php?domain=republican-eagle.com&tags=sports, high school,girls basketball, Lake City Tigers',type:'GET',dataType:'jsonp',crossDomain:true});
//--><!]]>
</script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/jsr_class.min.js?oii1q8"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?oii1q8"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_G8mSPrDqUT0jvAeB6lhOR3XaxjEZITO9rCPei8bVAos.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?oii1q8"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?oii1q8"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
// Quantcast Tag
        var ezt = ezt ||[];

        (function(){
          var elem = document.createElement('script');
          elem.src = (document.location.protocol == 'https:' ? 'https://secure' : 'http://pixel') + '.quantserve.com/aquant.js?a=p-f1gwFa5-x-0VY';
          elem.async = true;
          elem.type = 'text/javascript';
          var scpt = document.getElementsByTagName('script')[0];
          scpt.parentNode.insertBefore(elem,scpt);
        }());

        ezt.push({qacct: 'p-f1gwFa5-x-0VY',
            uid: '' });
      
//--><!]]>
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>

    <!-- Quantcast -->
    <noscript>
      <img src="//pixel.quantserve.com/pixel/p-f1gwFa5-x-0VY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
    </noscript>

    
        <div id='in-page-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('in-page-ad');
          });
        });
        </script>
        </div>
        <div id='wallpaper-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('wallpaper-ad');
          });
        });
        </script>
        </div>  </body>
</html>