<!DOCTYPE html PUBLIC "-//W3C//DTD HTML+RDFa 1.1//EN">
<html lang="en" dir="ltr" version="HTML+RDFa 1.1"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="author" content="Don Davis" />
<meta property="news_keywords" content="News,minnesota, Government, u.s. bank stadium, kathleen blatz, mark dayton, Sarah Anderson" />
<meta property="description" content="ST. PAUL — A former Minnesota Supreme Court chief justice drew the assignment of repairing the U.S. Bank Stadium governing board&#039;s tarnished image.&amp;quot;I..." />
<meta property="keywords" content="News,minnesota, Government, u.s. bank stadium, kathleen blatz, mark dayton, Sarah Anderson" />
<meta property="article:publisher" content="https://www.facebook.com/redwingrepublicaneagle" />
<meta property="article:tag" content="News,minnesota, Government, u.s. bank stadium, kathleen blatz, mark dayton, Sarah Anderson" />
<meta property="article:published_time" content="2017-02-24T16:00:00-06:00" />
<meta property="image:alt" content="Her new voluneer job as chairwoman of the U.S. Bank Stadium governing body is just an interim position, former Minnesota Chief Justice Kathleen Blatz said on Thursday, Feb. 23, 2017. Don Davis / Forum News Service" />
<meta property="article:modified_time" content="2017-02-24T16:00:00-06:00" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:title" content="Ex-chief justice takes over stadium board leadership" />
<meta property="twitter:image" content="http://www.republican-eagle.com/sites/default/files/styles/16x9_430/public/0BxgaMIwz3eorRk5CWjVQbkM1Nk0.jpg?itok=mDkm7Twi" />
<meta property="twitter:url" content="http://www.republican-eagle.com/news/4224206-ex-chief-justice-takes-over-stadium-board-leadership" />
<meta property="fb:app_id" content="243322109167890" />
<meta property="image:title" content="Her new voluneer job as chairwoman of the U.S. Bank Stadium governing body is just an interim position, former Minnesota Chief Justice Kathleen Blatz said on Thursday, Feb. 23, 2017. Don Davis / Forum News Service" />
<meta property="twitter:description" content="ST. PAUL — A former Minnesota Supreme Court chief justice drew the assignment of repairing the U.S. Bank Stadium governing board&#039;s tarnished image.&amp;quot;I want to build on that good and not lose sight of it,&amp;quot; Kathleen Blatz said Thursday, Feb. 23, about Gov. Mark Dayton&#039;s comments that most of..." />
<meta property="og:type" content="article" />
<meta property="og:description" content="ST. PAUL — A former Minnesota Supreme Court chief justice drew the assignment of repairing the U.S. Bank Stadium governing board&#039;s tarnished image.&amp;quot;I want to build on that good and not lose sight of it,&amp;quot; Kathleen Blatz said Thursday, Feb. 23, about Gov. Mark Dayton&#039;s comments that most of..." />
<meta property="og:url" content="http://www.republican-eagle.com/news/4224206-ex-chief-justice-takes-over-stadium-board-leadership" />
<meta property="og:image:width" content="300" />
<meta property="og:image" content="http://www.republican-eagle.com/sites/default/files/styles/square_300/public/0BxgaMIwz3eorRk5CWjVQbkM1Nk0.jpg?itok=XqQ9U5i4" />
<meta property="og:image:height" content="300" />
<meta property="og:title" content="Ex-chief justice takes over stadium board leadership" />
<link rel="shortcut icon" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/images/touch-icon.png" type="image/png" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<script type="application/javascript" src="https://content.jwplatform.com/libraries/R6N0vQlD.js" />
</script><link rel="amphtml" href="http://www.republican-eagle.com/news/4224206-ex-chief-justice-takes-over-stadium-board-leadership?amp" />
<link rel="shortlink" href="/node/4224206" />
<link rel="canonical" href="/news/4224206-ex-chief-justice-takes-over-stadium-board-leadership" />
    <title>Ex-chief justice takes over stadium board leadership | Republican Eagle</title>
    <link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_drAaZvIujzE0WQHPZOt8-T119XbC59ClvGgsZR7SC8M.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_n1pCl2MA43tzliKvK4qXdpArepfCRU6u4sc5BywLwKU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://unpkg.com/leaflet@1.0.2/dist/leaflet.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/css/article-slider.css?olvoae" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?olvoae" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/css/global-no-mqs.css?olvoae" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/css/global.css?olvoae" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_i9vAYWtv6IzHqwhy80-mNt0nMbj6ItfIIfYo9XNSP4I.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_NDvHtdToyr9KI_VRhvrkdvoS0h-5mbaC7nYaA4yn4c4.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-20', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript" src="https://unpkg.com/leaflet@1.0.2/dist/leaflet.js"></script>
<script type="text/javascript" src="https://api.fccinteractive.com/gmaps-kml-app/feeds/radar/js/min/radar.min.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_6LNmYXbJFrF_7W14muxt2N3zanu-C3tyGNx5A7k4lQ8.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?olvoae"></script>
<script type="text/javascript" src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?olvoae"></script>
<script type="text/javascript" src="//forumcomm-d.openx.net/w/1.0/jstag?nc=7021-Republican-Eagle"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

            if (jQuery(window).width() >= 728) {
              jQuery.getScript('//biddr.brealtime.com/49170050-648.js', function(data, textStatus, jqxhr) {
                console.log('loaded biddr.brealtime.com/49170050-648.js');
              });
            } else {
              jQuery.getScript('//biddr.brealtime.com/91130429-649.js', function(data, textStatus, jqxhr) {
                console.log('loaded biddr.brealtime.com/91130429-649.js');
              });
            }
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.districtm.ca/merge/all.forumcom.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_CGaraD_dIkCyfGw-2IxWXvZo3VT_wlgYWEqQCaW6yyk.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://a.postrelease.com/serve/load.js?async=true"></script>
<script type="text/javascript" src="https://cdn.connatix.com/min/connatix.renderer.destination.min.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1&amp;async=1&amp;domready=1"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4224206 node-type-article domain-www-republican-eagle-com context-news"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <li class="last">
            <a href="/register" title="Register">Register</a>
          </li>
        </ul>
            <div id='out-of-page-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('out-of-page-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class="menu"><li class="first leaf"><a href="http://www.carshq.com" title="">CarsHQ</a></li>
<li class="leaf"><a href="http://www.jobshq.com" title="">JobsHQ</a></li>
<li class="leaf"><a href="http://www.homeshq.com" title="">HomesHQ</a></li>
<li class="leaf"><a href="http://www.apartmentshq.com" title="">ApartmentsHQ</a></li>
<li class="leaf"><a href="/classifieds" title="">Classifieds</a></li>
<li class="last leaf"><a href="/marketplace_offers" title="">Marketplace</a></li>
</ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="Republican Eagle"><img src="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/logo.png" alt="Republican Eagle" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">Republican Eagle</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/news/4224206-ex-chief-justice-takes-over-stadium-board-leadership" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/business/4223113-sesquicentennial-farm-applications-due-april-3'>Sesquicentennial Farm applications due April 3</a></li><li><a href='/news/4224206-ex-chief-justice-takes-over-stadium-board-leadership'>Ex-chief justice takes over stadium board leadership</a></li><li><a href='/news/4223106-bluffs-brews-saturday-feb-25'>Bluffs &amp; Brews is Saturday, Feb. 25</a></li><li><a href='/news/region/4224499-despite-loss-red-wing-pride-soars'>Despite loss, Red Wing pride soars</a></li><li><a href='/news/education/4223605-rwhs-activities-recognition-night-feb-18'>RWHS activities recognition night is Feb. 18 </a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/tags/election-2016" target="_self">Election 2016</a></li><li><a href="/news/crime-and-courts" target="_self">crime and courts</a></li><li><a href="/news/government" target="_self">government</a></li><li><a href="/news/education" target="_self">education</a></li><li><a href="/news/business" target="_self">business</a></li><li><a href="/news/region" target="_self">region</a></li><li><a href="/news/accidents" target="_self">accidents</a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/4224384-birkie-canceled'>Update: &#039;Birkie&#039; canceled, but BirkieStock is on</a></li><li><a href='/sports/wingers/4224222-girls-basketball-red-wing-falls-regular-season-finale'>Girls Basketball: Red Wing falls in regular-season finale</a></li><li><a href='/sports/wingers/4224029-boys-hockey-comeback-complete'>Boys Hockey: Comeback complete</a></li><li><a href='/sports/high-school/4224214-girls-basketball-top-seeded-goodhue-advances'>Girls Basketball: Top-seeded Goodhue advances</a></li><li><a href='/sports/high-school/4224201-girls-basketball-k-w-handles-cannon-falls-1aa-opening-round'>Girls Basketball: K-W handles Cannon Falls in 1AA opening round</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/sports/high-school" target="_self">high school</a></li><li><a href="/sports/amateur" target="_self">amateur</a></li><li><a href="/sports/outdoors" target="_self">outdoors</a></li><li><a href="/sports/wingers" target="_self">wingers</a></li></ul></div></div></li><li class='leaf'><a href="/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/life/4223476-salsa-licious-fundraiser-returns-march-4'>Salsa-licious fundraiser returns March 4</a></li><li><a href='/life/events/4223602-benefit-set-aid-man-injured-2016-storm'>Benefit set to aid man injured in 2016 storm</a></li><li><a href='/life/events/4223103-spotlight-crossings-carnegie-exhibit'>Spotlight: Crossings at Carnegie exhibit</a></li><li><a href='/life/events/4223604-minnesota-author-discuss-award-winning-debut-mystery'>Minnesota author to discuss award-winning debut mystery</a></li><li><a href='/life/events/4223112-vienna-boys-choir-performs-smile-sheldon'>Vienna Boys Choir performs &#039;Smile&#039; at the Sheldon</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/life/arts-and-entertainment" target="_self">arts and entertainment</a></li><li><a href="/life/food" target="_self">food</a></li><li><a href="/life/health" target="_self">health</a></li><li><a href="/life/religion" target="_self">religion</a></li><li><a href="/life/family" target="_self">family</a></li><li><a href="/life/events" target="_self">events</a></li></ul></div></div></li><li class='leaf'><a href="/notices" target="_self">notices</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/legals/4223748-sum-25-cv-14-2381-axelson'>SUM 25-CV-14-2381 AXELSON</a></li><li><a href='/legals/4223747-minutes-1-17-2017'>MINUTES 1-17-2017</a></li><li><a href='/legals/4223746-minutes-1-17-2017'>MINUTES 1-17-2017</a></li><li><a href='/legals/4223745-board-comm-12-20-17'>BOARD OF COMM 12-20-17</a></li><li><a href='/legals/4223744-notice-election'>NOTICE OF ELECTION</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4224605-cody-james-skulski-25'>Cody James Skulski, 25</a></li><li><a href='/obituaries/4224450-frank-dement-87'>Frank Dement, 87</a></li><li><a href='/obituaries/4224448-robert-zibble-78'>Robert Zibble, 78</a></li><li><a href='/obituaries/4222391-donald-d-jennings-83'>Donald D. Jennings, 83</a></li><li><a href='/obituaries/4224449-ardelle-i-nesburg-81'>Ardelle I. Nesburg, 81</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/letters/4223592-letter-audubon-chapter-filled-great-folks'>Letter: Audubon chapter filled with great folks</a></li><li><a href='/opinion/letters/4223594-letter-community-promotes-children-and-arts'>Letter: Community promotes children and the arts</a></li><li><a href='/opinion/4221979-letter-tele-town-hall-form-censorship'>Letter: Tele-town hall is form of censorship</a></li><li><a href='/opinion/4221994-letters-questions-abound-hog-farm-issue'>Letters: Questions abound in hog farm issue</a></li><li><a href='/opinion/4221978-letters-equal-coverage-life-marches'>Letters: Equal coverage of &#039;Life Marches&#039;</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/columns" target="_self">columns</a></li><li><a href="/opinion/letters" target="_self">letters</a></li><li><a href="/opinion/editorials" target="_self">editorials</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="/basic-page/3729449-magazine-rack" target="_self">Magazine Rack</a></li><li class='leaf no-doormat'><a href="https://en.calameo.com/read/00073526136127b70bf45" target="_self">Real Estate Showcase</a></li><li class='leaf no-doormat'><a href="http://local.republican-eagle.com/ads" target="_self">Print Ads</a></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="News "> <meta itemprop='dateline' content="Red Wing,Minnesota 55066"> <meta itemprop='articleBody' content="&lt;p&gt;ST. PAUL — A former Minnesota Supreme Court chief justice drew the assignment of repairing the U.S. Bank Stadium governing board's tarnished image.&lt;/p&gt;&lt;p&gt;&quot;I want to build on that good and not lose sight of it,&quot; Kathleen Blatz said Thursday, Feb. 23, about Gov. Mark Dayton's comments that most of what the Minnesota Sports Facilities Authority has done is good.&lt;/p&gt;&lt;p&gt;Dayton named Blatz interim authority chairwoman after Michele Kelm-Helgen resigned as chairwoman amid a controversy in which authority officials took family and friends to Minnesota Vikings games and other events in luxury suites it has as a place to take potential stadium clients.&lt;/p&gt;&lt;p&gt;Thursday's appointment is temporary, Dayton said, as legislators look at ways to restructure the authority.&lt;/p&gt;&lt;p&gt;&quot;Emphasize interim,&quot; Blatz told reporters. &quot;I have no desire to continue on. I want to do a really good job now.&quot;&lt;/p&gt;&lt;p&gt;Blatz, a former Republican legislator before being appointed to the courts, said she will serve as chairwoman without pay. Kelm-Helgen received about $130,000 annually.&lt;/p&gt;&lt;p&gt;Dayton earlier appointed Blatz to the board, but it was so recent that she has not attended a meeting. Dayton said that he will not immediately fill her regular board position because legislators are examining the board's future.&lt;/p&gt;&lt;p&gt;Blatz said she is undergoing orientation and did not want to discuss specifics about what actions are needed to restore the authority reputation.&lt;/p&gt;&lt;p&gt;The Democratic governor restated his feeling that until the luxury box issue arose most of the authority did a good job, including making sure the $1 billion facility was completed on time and on budget. &quot;People deserve to know that.&quot;&lt;/p&gt;&lt;p&gt;The governor said that getting work done on time was important and he mentioned the state Capitol building, in which he stood, that remains under construction after its Dec. 30 planned multi-year renovation completion date.&lt;/p&gt;&lt;p&gt;The luxury suite controversy has bogged down the authority's work, Dayton said.&lt;/p&gt;&lt;p&gt;&quot;It is time we turn the page on this matter and deal with the totality of this project,&quot; the governor said.&lt;/p&gt;&lt;p&gt;Blatz runs her first authority meeting Friday, when the board is to consider what to do about an executive director vacancy. She said she did not expect anyone to be appointed Friday.&lt;/p&gt;&lt;p&gt;Ted Mondale resigned as executive last week, hours after Kelm-Helgen.&lt;/p&gt;&lt;p&gt;Blatz and Dayton avoided telling lawmakers how to redesign the authority.&lt;/p&gt;&lt;p&gt;But as a former lawmaker, Blatz said she would tell legislators: &quot;Keep your eye on the public. Do it for the public's benefit. A lot of these things can get into partisan politics.&quot;&lt;/p&gt;&lt;p&gt;An authority critic, Republican Rep. Sarah Anderson of Plymouth, praised the Blatz appointment.&lt;/p&gt;&lt;p&gt;&quot;This appointment is a good step forward toward fixing the problems with the management of the MSFA,&quot; Anderson said. &quot;I have immense respect for ... Blatz and believe she will be a partner in reforming how the MSFA operates. Minnesotans deserve transparency and accountability so the breaches of public trust by the MSFA board are not repeated.&quot;&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="Ex-chief justice takes over stadium board leadership"> <meta itemprop='author' content="Don Davis"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2017-02-24T16:00:00"> <meta itemprop='dateModified' content="2017-02-24T16:00:00"> <link itemprop='mainEntityOfPage' content="node/4224206"> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="http://www.republican-eagle.com/sites/default/files/styles/square_300/public/0BxgaMIwz3eorRk5CWjVQbkM1Nk0.jpg?itok=XqQ9U5i4"> <meta itemprop="width" content="6000"> <meta itemprop="height" content="4000"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Don Davis"> </div> <div itemscope itemtype='http://schema.org/Person'> <meta itemprop='affiliation' content="Republican Eagle"</span> <meta itemprop="name" content="Don Davis"> <meta itemprop="homeLocation" content="Red Wing"> <meta itemprop='url' content="http://www.republican-eagle.com"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="Ex-chief justice takes over stadium board leadership "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="Red Wing"> <meta itemprop='addressRegion' content="Minnesota"> <meta itemprop='streetAddress' content="2760 North Service Drive / P.O. Box 15"> <meta itemprop='postalCode' content="55066"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
        </script>
        </div><h1 class='node-title'>Ex-chief justice takes over stadium board leadership</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/don-davis-0'>Don Davis</a></span>
  <span class='node-byline-time'> Today  at 4:00 p.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-image-wrapper large article-slider'><button class='next'><img src='/sites/all/themes/fcc_basetheme/images/arrow-next.png'></button><button class='prev'><img src='/sites/all/themes/fcc_basetheme/images/arrow-back.png'></button><div class='individual-slide individual-slide-1' style='position: relative;'><img class='node-image large' src='http://www.republican-eagle.com/sites/default/files/styles/16x9_620/public/0BxgaMIwz3eorRk5CWjVQbkM1Nk0.jpg?itok=9FJfdAAx' data-featherlight='http://www.republican-eagle.com/sites/default/files/styles/full_1000/public/0BxgaMIwz3eorRk5CWjVQbkM1Nk0.jpg?itok=60w6jTpu'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Her new voluneer job as chairwoman of the U.S. Bank Stadium governing body is just an interim position, former Minnesota Chief Justice Kathleen Blatz said on Thursday, Feb. 23, 2017. Don Davis / Forum News Service</span><span class='slide-number'>1 / 2</span></div><div class='individual-slide individual-slide-2' style='position: relative;'><img class='node-image large' src='http://www.republican-eagle.com/sites/default/files/styles/16x9_620/public/0BxgaMIwz3eorV2x1MnlPRkFJWGc.jpg?itok=_4chr5hD' data-featherlight='http://www.republican-eagle.com/sites/default/files/styles/full_1000/public/0BxgaMIwz3eorV2x1MnlPRkFJWGc.jpg?itok=tnwa6VVn'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Former Minnesota Chief Justice Kathleen Blatz reacts after Gov. Mark Dayton named her interim chairwoman of the U.S. Bank Stadium governing body. Don Davis / Forum News Service</span><span class='slide-number'>2 / 2</span></div></div><div class='node-body'><p>ST. PAUL — A former Minnesota Supreme Court chief justice drew the assignment of repairing the U.S. Bank Stadium governing board's tarnished image.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_3tsbe7spkzmbtnshic4avgk3fe' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>"I want to build on that good and not lose sight of it," Kathleen Blatz said Thursday, Feb. 23, about Gov. Mark Dayton's comments that most of what the Minnesota Sports Facilities Authority has done is good.</p><p>Dayton named Blatz interim authority chairwoman after Michele Kelm-Helgen resigned as chairwoman amid a controversy in which authority officials took family and friends to Minnesota Vikings games and other events in luxury suites it has as a place to take potential stadium clients.</p><p>Thursday's appointment is temporary, Dayton said, as legislators look at ways to restructure the authority.</p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>"Emphasize interim," Blatz told reporters. "I have no desire to continue on. I want to do a really good job now."</p><p>Blatz, a former Republican legislator before being appointed to the courts, said she will serve as chairwoman without pay. Kelm-Helgen received about $130,000 annually.</p><p>Dayton earlier appointed Blatz to the board, but it was so recent that she has not attended a meeting. Dayton said that he will not immediately fill her regular board position because legislators are examining the board's future.</p><p>Blatz said she is undergoing orientation and did not want to discuss specifics about what actions are needed to restore the authority reputation.</p><p>The Democratic governor restated his feeling that until the luxury box issue arose most of the authority did a good job, including making sure the $1 billion facility was completed on time and on budget. "People deserve to know that."</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>The governor said that getting work done on time was important and he mentioned the state Capitol building, in which he stood, that remains under construction after its Dec. 30 planned multi-year renovation completion date.</p><p>The luxury suite controversy has bogged down the authority's work, Dayton said.</p><p>"It is time we turn the page on this matter and deal with the totality of this project," the governor said.</p><p>Blatz runs her first authority meeting Friday, when the board is to consider what to do about an executive director vacancy. She said she did not expect anyone to be appointed Friday.</p><p>Ted Mondale resigned as executive last week, hours after Kelm-Helgen.</p><p>Blatz and Dayton avoided telling lawmakers how to redesign the authority.</p><div id='jobsHQ-hotjobs-single-2' class='jobsHQ-hotjobs-single'></div><p>But as a former lawmaker, Blatz said she would tell legislators: "Keep your eye on the public. Do it for the public's benefit. A lot of these things can get into partisan politics."</p><p>An authority critic, Republican Rep. Sarah Anderson of Plymouth, praised the Blatz appointment.</p><p>"This appointment is a good step forward toward fixing the problems with the management of the MSFA," Anderson said. "I have immense respect for ... Blatz and believe she will be a partner in reforming how the MSFA operates. Minnesotans deserve transparency and accountability so the breaches of public trust by the MSFA board are not repeated."</p></div></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('third-mobile-ad');
          });
        </script>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='http://www.republican-eagle.com/taxonomy/term/1'>News</a><a class='topic tag' href='http://www.republican-eagle.com/taxonomy/term/318989'>minnesota</a><a class='topic tag' href='http://www.republican-eagle.com/taxonomy/term/220429'>Government</a><a class='topic tag' href='http://www.republican-eagle.com/taxonomy/term/270442'>u.s. bank stadium</a><a class='topic tag' href='http://www.republican-eagle.com/taxonomy/term/373774'>kathleen blatz</a><a class='topic tag' href='http://www.republican-eagle.com/taxonomy/term/133005'>mark dayton</a><a class='topic tag' href='http://www.republican-eagle.com/taxonomy/term/311334'>Sarah Anderson</a></div><div class='node-author-block clearfix'><a class='node-author-name' href='/users/don-davis-0'>Don Davis</a><div class='node-author-bio'>Don Davis has been the Forum Communications Minnesota Capitol Bureau chief since 2001, covering state government and politics for two dozen newspapers in the state. Don also blogs at <a href="http://capitolchat.areavoices.com/">Capital Chatter</a> on Areavoices.</div><div class='node-author-email'>
        <a href='/user/48878/contact'>
          <span itemprop='email'>ddavis@forumcomm.com</span>
        </a>
        </div></div><div id='ad-content-distribution'></div><div class='node-ad node-ad-mobile'>Advertisement<div id='marketplaceDeal_widget_mobile'></div></div><div id='fourth-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('fourth-mobile-ad');
          });
        </script>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',18);
  ga('send', 'event', 'article', 'paragraphs', '18');
  ga('send', 'event', 'article', 'length', 'characters',3115);
  ga('send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',14754);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',18);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '18');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',3115);
  ga('combinedSites.send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',14754);
</script>    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad odd block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class='node-ad node-ad-desktop'><div id='marketplaceDeal_widget' class='nocontent'></div></div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest even block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
      <div class="select-homepage">
      <a class="active trending" href="/trending">Trending</a>
    </div>
    <div class="space-eater-section fcc-trending">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/region/4224337-kenyon-goodhue-among-cities-hardest-hit-snowstorm"><span class="number">1. </span>Kenyon, Goodhue among cities hardest hit by snowstorm</a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/life/events/4223602-benefit-set-aid-man-injured-2016-storm"><span class="number">2. </span>Benefit set to aid man injured in 2016 storm</a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/news/region/4224499-despite-loss-red-wing-pride-soars"><span class="number">3. </span>Despite loss, Red Wing pride soars</a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/obituaries/4224448-robert-zibble-78"><span class="number">4. </span>Robert Zibble, 78</a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/sports/wingers/4224029-boys-hockey-comeback-complete"><span class="number">5. </span>Boys Hockey: Comeback complete</a></div>
      </div>
        <a class="more" href="/trending">more <span class="arrow">〉</span></a>
</div>
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/business/4223113-sesquicentennial-farm-applications-due-april-3">Sesquicentennial Farm applications due April 3<span class='latest-date'>1 hour ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/life/4223476-salsa-licious-fundraiser-returns-march-4">Salsa-licious fundraiser returns March 4<span class='latest-date'>2 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/sports/4224384-birkie-canceled">Update: 'Birkie' canceled, but BirkieStock is on<span class='latest-date'>3 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/news/4224206-ex-chief-justice-takes-over-stadium-board-leadership">Ex-chief justice takes over stadium board leadership<span class='latest-date'>4 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/news/4223106-bluffs-brews-saturday-feb-25">Bluffs & Brews is Saturday, Feb. 25<span class='latest-date'>4 hours ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-fcc-advertising block-wishabi-article block-fcc-advertising-wishabi-article odd block-without-title" id="block-fcc-advertising-wishabi-article">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Wishabi Circular widget on Article -->
          <div id='circularhub_module_6251' class='nocontent'></div>
          <script src='http://api.flyertown.ca/6251/2abb546c0a8af6a5/circularhub_module.js'></script>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget even block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><section class="block block-views block-classified-featured-block block-views-classified-featured-block odd" id="block-views-classified-featured-block">
  <div class="block-inner clearfix">
              <h2 class="block-title">Top Ads</h2>
            
    <div class="content clearfix">
      <div class="view view-classified-featured view-id-classified_featured view-display-id-block view-dom-id-0e94c400f49dca86ab91ec335e1ced2e">
    
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2440488">
      COMMERCIAL SPACE available in new building with nice convenient location!  <br>Commercial Park off Hwy C., Somerset, WI.  <br> <br>    </a>
    </span>
  </p>
  </div>
  </div>
  <div class="views-row views-row-2 views-row-even top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2449222">
      Cupids Last Chance!  <br>Craft & Vendor Shopping Event! <br>Feb. 11th  10am-3pm   <br>at the Machine Shed- 8515 Hudson Blvd. N    </a>
    </span>
  </p>
  </div>
  </div>
  <div class="views-row views-row-3 views-row-odd top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2451488">
      Jeff's Small Engine and Shock Rebuilding. Snowmobiles, Snow Blowers, Lawn Care Equipment. Jeff Hendricks 960 Florence Ln Hudson WI 54016 cell:    </a>
    </span>
  </p>
  </div>
  </div>
  <div class="views-row views-row-4 views-row-even views-row-last top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2440499">
      WE BUY AND TOW Unwanted and Wrecked Vehicles.   <br>MN Licensed Dealer.   <br>Call for Quote: 651-322-1800   <br>www.upullrparts.com    </a>
    </span>
  </p>
  </div>
  </div>
    </div>
              <span class="class-11px"><a href="/classifieds/featured">View all top ads &raquo;</a></span>
</div>    </div>
  </div>
</section><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget even block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-homeshq-widget block-boxes-homeshq-widget odd block-without-title" id="block-boxes-homeshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-homeshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="homes_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget even block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('bottom-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='https://newspaper.forumcomm.com/cgi-bin/cmo_cmo.sh/custservice/web/login2.html?siteid=RRE' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/republican-eagle" title="">Subscribe to the Paper</a></li>      <li><a href="http://www.newspaperprints.com" title="">Buy Newspaper Prints</a></li>
      <li><a href="http://www.rivertownmultimedia.com">Advertise with us</a></li>    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="http://forumcomm.desk.com/" title="">Get Website Help</a></li>
      <li><a href="http://www.jobshq.com/employers/page/profile/employer/34/" title="">Work With Us</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="http://www.jobshq.com" target="_blank" title="">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="">CarsHQ</a></li>
      <li><a href="http://www.homeshq.com" target="_blank" title="">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="">Northland Outdoors</a></li>
      <li><a href="http://www.agweek.com" target="_blank" title="">Agweek</a></li>
      <li><a href="http://impact.areavoices.com" target="_blank" title="">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://www.twitter.com/republicaneagle" title="Find us on Twitter"><img alt="Find us on Twitter" src="/sites/all/themes/fcc_basetheme/images/icons/twitter-social.png" /> Twitter</a></li><li><a href="https://www.facebook.com/redwingrepublicaneagle" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li><li><a href="https://plus.google.com/102646955521009741833/" title="Find us on Google+" rel="publisher"><img alt="Find us on Google+" src="/sites/all/themes/fcc_basetheme/images/icons/google-social.png" /> Google+</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; Republican Eagle</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; Republican Eagle</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">2760 North Service Drive / P.O. Box 15</div>
      <span class="locality">Red Wing</span>, 
      <span class="region">Minnesota</span> 
      <span class="postal-code">55066</span>
    </div>

    Call us at <div class="tel">651-388-8235</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div style="display: none;"><a rel="nofollow" href="http://www.fccnn.com/newspaper.php">randomness</a></div>  </div>
</div><script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.ajax({url:'http://itracking.fccinteractive.com/tracking/drupalcms/insert_impressions.php?domain=republican-eagle.com&tags=News,minnesota, Government, u.s. bank stadium, kathleen blatz, mark dayton, Sarah Anderson',type:'GET',dataType:'jsonp',crossDomain:true});
//--><!]]>
</script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/jsr_class.min.js?olvoae"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?olvoae"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_JozVjTMXs55bUfFMpJpqqcKwp4OKeoevi65GD95_4ys.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function(){addthis.init()});
//--><!]]>
</script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_fmp1S-5y78PyIlN6garUecXqzFXRTmkF862CNm-d-30.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?olvoae"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?olvoae"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
// Quantcast Tag
        var ezt = ezt ||[];

        (function(){
          var elem = document.createElement('script');
          elem.src = (document.location.protocol == 'https:' ? 'https://secure' : 'http://pixel') + '.quantserve.com/aquant.js?a=p-f1gwFa5-x-0VY';
          elem.async = true;
          elem.type = 'text/javascript';
          var scpt = document.getElementsByTagName('script')[0];
          scpt.parentNode.insertBefore(elem,scpt);
        }());

        ezt.push({qacct: 'p-f1gwFa5-x-0VY',
            uid: '' });
      
//--><!]]>
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>

    <!-- Quantcast -->
    <noscript>
      <img src="//pixel.quantserve.com/pixel/p-f1gwFa5-x-0VY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
    </noscript>

    
        <div id='in-page-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('in-page-ad');
          });
        </script>
        </div>
        <div id='wallpaper-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('wallpaper-ad');
          });
        </script>
        </div>  </body>
</html>