<!DOCTYPE html PUBLIC "-//W3C//DTD HTML+RDFa 1.1//EN">
<html lang="en" dir="ltr" version="HTML+RDFa 1.1"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="keywords" content="Life, arts and entertainment,Arts, Entertainment" />
<meta property="news_keywords" content="Life, arts and entertainment,Arts, Entertainment" />
<meta property="description" content="Get out your maid&#039;s uniform and fishnet stockings, your ruby lipstick and magenta wig, your sequined corset and doctors&#039; scrubs — it&#039;s that time of year again.&amp;quot;The..." />
<meta property="author" content="Red Wing Newsroom" />
<meta property="article:published_time" content="2017-10-22T08:54:00-05:00" />
<meta property="article:modified_time" content="2017-10-22T08:54:00-05:00" />
<meta property="article:author" content="https://www.facebook.com/redwingrepublicaneagle" />
<meta property="twitter:url" content="http://www.republican-eagle.com/life/arts-and-entertainment/4346035-celebrate-halloween-rocky-horror-picture-show" />
<meta property="article:publisher" content="https://www.facebook.com/redwingrepublicaneagle" />
<meta property="article:tag" content="Life, arts and entertainment,Arts, Entertainment" />
<meta property="twitter:title" content="Celebrate Halloween at &#039;Rocky Horror Picture Show&#039;" />
<meta property="fb:app_id" content="243322109167890" />
<meta property="twitter:description" content="Get out your maid&#039;s uniform and fishnet stockings, your ruby lipstick and magenta wig, your sequined corset and doctors&#039; scrubs — it&#039;s that time of year again.&amp;quot;The Rocky Horror Picture Show&amp;quot; is back and it&#039;s going to be an event, not just a film. The Sheldon Theatre is spotlighting the cult..." />
<meta property="twitter:image" content="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/images/touch-icon.png" />
<meta property="twitter:card" content="summary" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Get out your maid&#039;s uniform and fishnet stockings, your ruby lipstick and magenta wig, your sequined corset and doctors&#039; scrubs — it&#039;s that time of year again.&amp;quot;The Rocky Horror Picture Show&amp;quot; is back and it&#039;s going to be an event, not just a film. The Sheldon Theatre is spotlighting the cult..." />
<meta property="og:url" content="http://www.republican-eagle.com/life/arts-and-entertainment/4346035-celebrate-halloween-rocky-horror-picture-show" />
<meta property="og:image:width" content="200" />
<meta property="og:image" content="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/images/touch-icon.png" />
<meta property="og:title" content="Celebrate Halloween at &#039;Rocky Horror Picture Show&#039;" />
<meta property="og:image:height" content="200" />
<link rel="apple-touch-icon" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/images/touch-icon.png" type="image/png" />
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<link rel="shortcut icon" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/favicon.ico" type="image/x-icon" />
<link rel="amphtml" href="http://www.republican-eagle.com/life/arts-and-entertainment/4346035-celebrate-halloween-rocky-horror-picture-show?amp" />
<script type="application/javascript" src="https://content.jwplatform.com/libraries/R6N0vQlD.js" />
</script><link rel="shortlink" href="/node/4346035" />
<link rel="canonical" href="/life/arts-and-entertainment/4346035-celebrate-halloween-rocky-horror-picture-show" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
    <title>Celebrate Halloween at &#039;Rocky Horror Picture Show&#039; | Republican Eagle</title>
    <link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_drAaZvIujzE0WQHPZOt8-T119XbC59ClvGgsZR7SC8M.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_dn1Z7ijuixoG-wMmyYi-2wgXq6gNxLsgC7vdi2dJMWs.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://unpkg.com/leaflet@1.0.3/dist/leaflet.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/css/article-slider.css?oy50av" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?oy50av" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/css/global-no-mqs.css?oy50av" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/css/global.css?oy50av" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="http://www.republican-eagle.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_F77Wk3ElhI0IWc9W9h5jNjw2XWOBI81sjCu16e_P21s.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_NDvHtdToyr9KI_VRhvrkdvoS0h-5mbaC7nYaA4yn4c4.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-20', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript" src="https://unpkg.com/leaflet@1.0.3/dist/leaflet.js"></script>
<script type="text/javascript" src="https://api.fccinteractive.com/gmaps-kml-app/feeds/radar/js/min/radar.min.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_6LNmYXbJFrF_7W14muxt2N3zanu-C3tyGNx5A7k4lQ8.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?oy50av"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?oy50av"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

       var OX_dfp_options = {prefetch: true};
       if (jQuery(window).width() >= 728) {
         var OX_dfp_ads = [
            ['/7021/fcc.forum/republican-eagle', ['300x250', '120x600', '160x600', '300x600'], 'article-sidebar-ad'],
            ['/7021/fcc.forum/republican-eagle', ['728x90', '980x330', '960x200', '930x180', '970x90', '970x250', '970x66', '980x120'], 'top-leaderboard-ad'],
            ['/7021/fcc.forum/republican-eagle', ['728x90', '320,100', '320,50', '300,50'], 'mid-leaderboard-ad'],
            ['/7021/fcc.forum/republican-eagle', ['728x90', '980x330', '960x200', '930x180', '970x90', '970x250', '970x66', '980x120'], 'bottom-leaderboard-ad'],
            ['/7021/fcc.forum/republican-eagle', ['300x250', '320x100', '320x50', '300x50'], 'photo-gallery-ad'],
          ];
        } else {
          var OX_dfp_ads = [
            ['/7021/fcc.forum/republican-eagle', ['300x100', '320x50', '300x50'], 'first-mobile-ad'],
            ['/7021/fcc.forum/republican-eagle', ['320x100', '320x50', '300x50'], 'second-mobile-ad'],
            ['/7021/fcc.forum/republican-eagle', ['320x100', '320x50', '300x50'], 'third-mobile-ad'],
            ['/7021/fcc.forum/republican-eagle', ['320x100', '320x50', '300x50'], 'fourth-mobile-ad'],
          ];
        }
//--><!]]>
</script>
<script type="text/javascript" src="//forumcomm-d.openx.net/w/1.0/jstag?nc=7021-Republican-Eagle"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript" src="//biddr.brealtime.com/28228967-1007.js"></script>
<script type="text/javascript" src="//cdn.districtm.ca/merge/all.forumcom.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_CGaraD_dIkCyfGw-2IxWXvZo3VT_wlgYWEqQCaW6yyk.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_Y1rdwRgUs4JbtR_PFE950_FKiFhHKa6FjSWv_MUBj8g.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1&amp;async=1&amp;domready=1"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4346035 node-type-article domain-www-republican-eagle-com context-life"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <!--<li class="last">
            <a href="/register" title="Register">Register</a>
          </li>-->
        </ul>
                </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class="menu"><li class="first leaf"><a href="http://www.carshq.com" title="CarsHQ">CarsHQ</a></li>
<li class="leaf"><a href="http://www.jobshq.com" title="JobsHQ">JobsHQ</a></li>
<li class="leaf"><a href="http://www.homeshq.com" title="HomesHQ">HomesHQ</a></li>
<li class="leaf"><a href="http://www.apartmentshq.com" title="ApartmentsHQ">ApartmentsHQ</a></li>
<li class="leaf"><a href="/classifieds" title="Classifieds">Classifieds</a></li>
<li class="last leaf"><a href="/marketplace_offers" title="Marketplace">Marketplace</a></li>
</ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="Republican Eagle"><img src="http://www.republican-eagle.com/sites/all/themes/republicaneagle_theme/logo.png" alt="Republican Eagle" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">Republican Eagle</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/life/arts-and-entertainment/4346035-celebrate-halloween-rocky-horror-picture-show" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div id="zone-menu-anchor"></div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf logo'><a href='/'><img src='/sites/all/themes/republicaneagle_theme/logo.png' /></a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/region/4347263-tips-and-tricks-safe-halloween'>Tips and tricks for a safe Halloween</a></li><li><a href='/news/region/4346929-prairie-island-refueling-unit-2'>Prairie Island refueling Unit 2</a></li><li><a href='/news/region/4346039-crane-operators-view'>From a crane operator&#039;s view</a></li><li><a href='/news/business/4346227-farm-market-report-oct-17-zumbrota-livestock-auction-market'>Farm market report for Oct. 17 from the Zumbrota Livestock Auction Market</a></li><li><a href='/news/region/4346033-lane-closure-west-seventh-street'>Lane closure on West Seventh Street</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/news/crime-and-courts" target="_self">crime and courts</a></li><li><a href="/news/government" target="_self">government</a></li><li><a href="/news/education" target="_self">education</a></li><li><a href="/news/business" target="_self">business</a></li><li><a href="/news/region" target="_self">region</a></li><li><a href="/news/accidents" target="_self">accidents</a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/wingers/4346636-football-mankato-west-pounds-red-wing-postseason-next'>Football: Mankato West pounds Red Wing, postseason next</a></li><li><a href='/sports/high-school/4346080-area-football-wrap-goodhue-wins-southland-clinches-no-1-seed'>Area Football Wrap: Goodhue wins at Southland, clinches No. 1 seed</a></li><li><a href='/sports/high-school/4346002-football-lourdes-overpowers-pine-island'>Football: Lourdes overpowers Pine Island</a></li><li><a href='/sports/wingers/4345938-girls-swimming-red-wing-ends-dual-season-loss'>Girls Swimming: Red Wing ends dual season with a loss</a></li><li><a href='/sports/high-school/4345898-cross-country-k-m-boys-stewartville-girls-top-hvl'>Cross-Country: K-M boys, Stewartville girls top the HVL</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/sports/high-school" target="_self">high school</a></li><li><a href="/sports/amateur" target="_self">amateur</a></li><li><a href="/sports/outdoors" target="_self">outdoors</a></li><li><a href="/sports/wingers" target="_self">wingers</a></li></ul></div></div></li><li class='leaf'><a href="/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/life/arts-and-entertainment/4346035-celebrate-halloween-rocky-horror-picture-show'>Celebrate Halloween at &#039;Rocky Horror Picture Show&#039;</a></li><li><a href='/life/arts-and-entertainment/4346926-extraordinist-karges-brings-magic-sheldon-stage'>&#039;Extraordinist&#039; Karges brings magic to Sheldon stage</a></li><li><a href='/life/arts-and-entertainment/4346705-elevating-arts-red-wing'>Elevating the arts in Red Wing</a></li><li><a href='/life/events/4346043-virtual-museum-launched-honor-tuskegee-airmen'>Virtual museum launched to honor Tuskegee Airmen</a></li><li><a href='/life/4346037-wiemer-and-tonder-exhibit-open-oct-20'>Wiemer and Tonder exhibit to open Oct. 20</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/life/arts-and-entertainment" target="_self">arts and entertainment</a></li><li><a href="/life/food" target="_self">food</a></li><li><a href="/life/health" target="_self">health</a></li><li><a href="/life/religion" target="_self">religion</a></li><li><a href="/life/family" target="_self">family</a></li><li><a href="/life/events" target="_self">events</a></li></ul></div></div></li><li class='leaf'><a href="/notices" target="_self">notices</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/legals/4346515-red-wing-rfb-waste-management-facility-demolition'>Red Wing RFB Waste Management Facility Demolition</a></li><li><a href='/legals/4346514-board-commissioners-proceedings-goodhue-county-mn-september-19-2017'>BOARD OF COMMISSIONERS&#039; PROCEEDINGS, GOODHUE COUNTY, MN SEPTEMBER 19, 2017</a></li><li><a href='/legals/4335712-midfirst-bank-v-diane-k-williams-et-al'>MidFirst Bank v. Diane K. Williams, et al</a></li><li><a href='/legals/4328350-pennymac-loan-services-v-brian-forsell'>PennyMac Loan Services v. Brian Forsell</a></li><li><a href='/legals/4345031-deutsche-bank-trust-co-americas-vs-kevin-bach'>Deutsche Bank Trust Co. Americas vs Kevin  Bach</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4346180-lowell-r-payton'>Lowell R. Payton</a></li><li><a href='/obituaries/4344152-thomas-bartlett'>Thomas A. Bartlett</a></li><li><a href='/obituaries/4344968-earl-ludwig-anderson'>Earl Ludwig Anderson</a></li><li><a href='/obituaries/4344918-vivian-m-brage'>Vivian M. Brage</a></li><li><a href='/obituaries/4344917-florence-bremer'>Florence Bremer</a></li></ul></div></div></li><li class='leaf'><a href="/milestones" target="_self">milestones</a><div class='doormat-menu'><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/milestones/anniversaries" target="_self">anniversaries</a></li><li><a href="/milestones/birthdays" target="_self">birthdays</a></li><li><a href="/milestones/engagements" target="_self">engagements</a></li><li><a href="/milestones/new-arrivals" target="_self">new arrivals</a></li><li><a href="/milestones/weddings" target="_self">weddings</a></li><li><a href="/milestones/other-celebrations" target="_self">other celebrations</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/letters/4346031-letter-trump-delivers-ramblings-not-speech'>Letter: Trump delivers ramblings, not a speech</a></li><li><a href='/opinion/columns/4346018-column-2018-election-will-require-investment'>Column: The 2018 election will require investment</a></li><li><a href='/opinion/letters/4346017-letter-change-makers-aims-boost-women-leaders'>Letter: Change Makers aims to boost women leaders</a></li><li><a href='/opinion/columns/4345986-ward-column-work-buttonhook-ramp-takes-shape'>Ward column: Work on buttonhook ramp takes shape</a></li><li><a href='/opinion/letters/4346027-letter-remember-amos-owen-support-human-rights-honor-current-resident'>Letter: Remember Amos Owen, support human rights, honor a current resident</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/columns" target="_self">columns</a></li><li><a href="/opinion/letters" target="_self">letters</a></li><li><a href="/opinion/editorials" target="_self">editorials</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="/basic-page/3729449-magazine-rack" target="_self">Magazine Rack</a></li><li class='leaf no-doormat'><a href="http://en.calameo.com/read/000735261cd5e58060ce8" target="_self">Real Estate Showcase</a><div class='doormat-menu'><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="http://www.rivertownlistings.com/" target="_self">Real Estate Showcase Ad Submission</a></li><li><a href="http://en.calameo.com/read/000735261cd5e58060ce8" target="_self">Real Estate Showcase current ads</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="http://local.republican-eagle.com/ads" target="_self">Print Ads</a></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="Life "> <meta itemprop='dateline' content="Red Wing,Minnesota 55066"> <meta itemprop='articleBody' content="&lt;p&gt;Get out your maid's uniform and fishnet stockings, your ruby lipstick and magenta wig, your sequined corset and doctors' scrubs — it's that time of year again.&lt;/p&gt;&lt;p&gt;&quot;The Rocky Horror Picture Show&quot; is back and it's going to be an event, not just a film. The Sheldon Theatre is spotlighting the cult classic as part of its Halloween weekend celebration. It will be shown on the big screen at 7:30 p.m. Friday, Oct. 27.&lt;/p&gt;&lt;p&gt;.&quot;Rocky Horror&quot; has been inspiring movie-goers since it was released in 1975. Billed as a &quot;British-American musical screwball comedy-horror film,&quot; it was largely panned by critics.&lt;/p&gt;&lt;p&gt;But audiences embraced it as a humorous musical tribute to the science fiction and &quot;B&quot; horror movies of the late 1940s through the early 1970s.&lt;/p&gt;&lt;p&gt;The story follows the adventures of a newly engaged couple (Barry Bostwick and Susan Sarandon) who are caught in a storm when they get a flat tire.&lt;/p&gt;&lt;p&gt;They come to the home of a mad transvestite scientist, Dr. Frank N. Furter (Tim Curry), who is having a party to unveil his new creation — a manmade Adonis named Rocky Horror. And he's just one of the kinky characters they encounter in the eerie mansion.&lt;/p&gt;&lt;p&gt;Not long after its debut, audiences discovered they enjoyed the film more if they &quot;participated&quot; in the screening by talking back to the screen, dressing as the characters, acting out the story, singing &quot;The Time Warp&quot; and other movie tunes, and tossing film props such as playing cards, toilet paper and party hats.&lt;/p&gt;&lt;p&gt;Admission to &quot;The Rocky Horror Picture Show&quot; is $10. Visit the box office, call 651-388-8700 or go online to www.sheldontheatre.org.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="Celebrate Halloween at 'Rocky Horror Picture Show'"> <meta itemprop='author' content="Red Wing Newsroom"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2017-10-22T08:53:33"> <meta itemprop='dateModified' content="2017-10-22T08:54:00"> <link itemprop='mainEntityOfPage' content="node/4346035"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Red Wing Newsroom"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="Celebrate Halloween at 'Rocky Horror Picture Show' "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="Red Wing"> <meta itemprop='addressRegion' content="Minnesota"> <meta itemprop='streetAddress' content="2760 North Service Drive / P.O. Box 15"> <meta itemprop='postalCode' content="55066"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
        </script>
        </div><h1 class='node-title'>Celebrate Halloween at 'Rocky Horror Picture Show'</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/renews'>Red Wing Newsroom</a></span>
  <span class='node-byline-time'> Today  at 8:53 a.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-body'><p>Get out your maid's uniform and fishnet stockings, your ruby lipstick and magenta wig, your sequined corset and doctors' scrubs — it's that time of year again.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_3tsbe7spkzmbtnshic4avgk3fe' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>"The Rocky Horror Picture Show" is back and it's going to be an event, not just a film. The Sheldon Theatre is spotlighting the cult classic as part of its Halloween weekend celebration. It will be shown on the big screen at 7:30 p.m. Friday, Oct. 27.</p><p>."Rocky Horror" has been inspiring movie-goers since it was released in 1975. Billed as a "British-American musical screwball comedy-horror film," it was largely panned by critics.</p><p>But audiences embraced it as a humorous musical tribute to the science fiction and "B" horror movies of the late 1940s through the early 1970s.</p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>The story follows the adventures of a newly engaged couple (Barry Bostwick and Susan Sarandon) who are caught in a storm when they get a flat tire.</p><p>They come to the home of a mad transvestite scientist, Dr. Frank N. Furter (Tim Curry), who is having a party to unveil his new creation — a manmade Adonis named Rocky Horror. And he's just one of the kinky characters they encounter in the eerie mansion.</p><p>Not long after its debut, audiences discovered they enjoyed the film more if they "participated" in the screening by talking back to the screen, dressing as the characters, acting out the story, singing "The Time Warp" and other movie tunes, and tossing film props such as playing cards, toilet paper and party hats.</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>Admission to "The Rocky Horror Picture Show" is $10. Visit the box office, call 651-388-8700 or go online to <a href="http://www.sheldontheatre.org">www.sheldontheatre.org</a>.</p></div><div style='clear:both;'></div><script type='text/javascript'>
							ga('send','event','Recommended','view','recommended-view');
							ga('combinedSites.send','event','Recommended','view','recommended-view');
						</script><script type='text/javascript'>
      	ga('send', 'event', 'Recommended', 'view with image', 'recommended-view');
      	ga('combinedSites.send', 'event', 'Recommended', 'view with image', 'recommended-view');
      </script><script type='text/javascript'>
      	ga('send', 'event', 'Recommended', 'view with image', 'recommended-view');
      	ga('combinedSites.send', 'event', 'Recommended', 'view with image', 'recommended-view');
      </script><script type='text/javascript'>
      	ga('send', 'event', 'Recommended', 'view without image', 'recommended-view');
      	ga('combinedSites.send', 'event', 'Recommended', 'view without image', 'recommended-view');
      </script><div class='recommended node-ad-desktop nocontent'><div class="header-recommendation-engine-block">Additional Articles Recommended by Republican Eagle</div><div class="title-recommendation-engine-block"><a class="with-img" href="http://www.republican-eagle.com/node/4342133"><img typeof="foaf:Image" src="http://www.republican-eagle.com/sites/default/files/styles/16x9_315/public/0B9KPC4_HI9veRWF3a2dlX000QU0.jpg?itok=v1QAA0bQ" alt="Davy Knowles brings blues and rock to the Zumbrota State Theatre on Friday, Oct. 20. Photo courtesy of Crossings at Carnegie" title="Davy Knowles brings blues and rock to the Zumbrota State Theatre on Friday, Oct. 20. Photo courtesy of Crossings at Carnegie" />Knowles takes State Theatre stage Oct. 20</a></div><div class="title-recommendation-engine-block"><a class="with-img" href="http://www.republican-eagle.com/node/4341448"><img typeof="foaf:Image" src="http://www.republican-eagle.com/sites/default/files/styles/16x9_315/public/0B9KPC4_HI9veQTlpbEdJQmF6TFk.jpg?itok=dAJzkbeS" alt="Thrill to new and old favorites covered by Hornucopia" title="Thrill to new and old favorites covered by Hornucopia" />Hornucopia: A tribute to horns in the rock era</a></div><div class="title-recommendation-engine-block"><a class="without-img" href="http://www.republican-eagle.com/node/4346029">Red Wing Arts announces winners of 2017 Arts Festival</a></div></div><script type='text/javascript'>
					jQuery('.recommended.node-ad-desktop a').on('click', function() {
						ga('send', 'event', 'Recommended', 'click', 'recommended-click');
						ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
					});
				</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-desktop a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-desktop a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'><div class="header-recommendation-engine-block">Additional Articles Recommended by Republican Eagle</div><div class="title-recommendation-engine-block"><a class="with-img" href="http://www.republican-eagle.com/node/4342133"><img typeof="foaf:Image" src="http://www.republican-eagle.com/sites/default/files/styles/16x9_315/public/0B9KPC4_HI9veRWF3a2dlX000QU0.jpg?itok=v1QAA0bQ" alt="Davy Knowles brings blues and rock to the Zumbrota State Theatre on Friday, Oct. 20. Photo courtesy of Crossings at Carnegie" title="Davy Knowles brings blues and rock to the Zumbrota State Theatre on Friday, Oct. 20. Photo courtesy of Crossings at Carnegie" />Knowles takes State Theatre stage Oct. 20</a></div><div class="title-recommendation-engine-block"><a class="with-img" href="http://www.republican-eagle.com/node/4341448"><img typeof="foaf:Image" src="http://www.republican-eagle.com/sites/default/files/styles/16x9_315/public/0B9KPC4_HI9veQTlpbEdJQmF6TFk.jpg?itok=dAJzkbeS" alt="Thrill to new and old favorites covered by Hornucopia" title="Thrill to new and old favorites covered by Hornucopia" />Hornucopia: A tribute to horns in the rock era</a></div><div class="title-recommendation-engine-block"><a class="without-img" href="http://www.republican-eagle.com/node/4346029">Red Wing Arts announces winners of 2017 Arts Festival</a></div></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('third-mobile-ad');
          });
        </script>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='http://www.republican-eagle.com/taxonomy/term/3128'>Life</a><a class='topic category' href='http://www.republican-eagle.com/taxonomy/term/26910'>arts and entertainment</a><a class='topic tag' href='http://www.republican-eagle.com/taxonomy/term/220182'>Arts</a><a class='topic tag' href='http://www.republican-eagle.com/taxonomy/term/220248'>Entertainment</a></div><div id='ad-content-distribution'></div><div class='node-ad node-ad-mobile'>Advertisement<div id='marketplaceDeal_widget_mobile'></div></div><div id='fourth-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('fourth-mobile-ad');
          });
        </script>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',8);
  ga('send', 'event', 'article', 'paragraphs', '8');
  ga('send', 'event', 'article', 'length', 'characters',1686);
  ga('send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',32689);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',8);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '8');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',1686);
  ga('combinedSites.send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',32689);
</script>    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad odd block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class='node-ad node-ad-desktop'><div id='marketplaceDeal_widget' class='nocontent'></div></div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest even block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/life/arts-and-entertainment/4346035-celebrate-halloween-rocky-horror-picture-show">Celebrate Halloween at 'Rocky Horror Picture Show'<span class='latest-date'>9 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/life/arts-and-entertainment/4346926-extraordinist-karges-brings-magic-sheldon-stage">'Extraordinist' Karges brings magic to Sheldon stage<span class='latest-date'>11 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/news/region/4347263-tips-and-tricks-safe-halloween">Tips and tricks for a safe Halloween<span class='latest-date'>1 day ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/opinion/letters/4346031-letter-trump-delivers-ramblings-not-speech">Letter: Trump delivers ramblings, not a speech<span class='latest-date'>1 day ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/news/region/4346929-prairie-island-refueling-unit-2">Prairie Island refueling Unit 2<span class='latest-date'>2 days ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-5">
        <div class="space-eater-headline class-14px"><a href="/life/arts-and-entertainment/4346705-elevating-arts-red-wing">Elevating the arts in Red Wing<span class='latest-date'>2 days ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-6">
        <div class="space-eater-headline class-14px"><a href="/opinion/columns/4346018-column-2018-election-will-require-investment">Column: The 2018 election will require investment<span class='latest-date'>2 days ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-7">
        <div class="space-eater-headline class-14px"><a href="/sports/wingers/4346636-football-mankato-west-pounds-red-wing-postseason-next">Football: Mankato West pounds Red Wing, postseason next<span class='latest-date'>2 days ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget odd block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget even block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget odd block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('bottom-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='https://newspaper.forumcomm.com/cgi-bin/cmo_cmo.sh/custservice/web/login2.html?siteid=RRE' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/republican-eagle" title="">Subscribe to the Paper</a></li><li><a href="http://digital.olivesoftware.com/Olive/ODN/redwingrepublicaneagle/Default.aspx" title="Access E-Paper">Access E-Paper</a></li>      <li><a href="http://www.rivertownmultimedia.com">Advertise with us</a></li>    </ul>
  </section>
</div>
<div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="mailto:customerservice+republican-eagle.com@forumcomm.com" title="">Get Website Help</a></li>
      <li><a href="http://www.forumcomm.com/careers/" title="">Work With Us</a></li>
    </ul>
  </section>
</div>
<div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="http://www.jobshq.com" target="_blank" title="JobsHQ">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="CarsHQ">CarsHQ</a></li>
      <li><a href="http://www.homeshq.com" target="_blank" title="HomesHQ">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="Northland Outdoors">Northland Outdoors</a></li>
      <li><a href="http://www.agweek.com" target="_blank" title="Agweek">Agweek</a></li>
      <li><a href="http://impact.areavoices.com" target="_blank" title="Impact Magazine">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://www.twitter.com/republicaneagle" title="Find us on Twitter"><img alt="Find us on Twitter" src="/sites/all/themes/fcc_basetheme/images/icons/twitter-social.png" /> Twitter</a></li><li><a href="https://www.facebook.com/redwingrepublicaneagle" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li><li><a href="https://plus.google.com/102646955521009741833/" title="Find us on Google+" rel="publisher"><img alt="Find us on Google+" src="/sites/all/themes/fcc_basetheme/images/icons/google-social.png" /> Google+</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; Republican Eagle</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; Republican Eagle</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">2760 North Service Drive / P.O. Box 15</div>
      <span class="locality">Red Wing</span>, 
      <span class="region">Minnesota</span> 
      <span class="postal-code">55066</span>
    </div>

    Call us at <div class="tel">651-388-8235</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <!-- <a href="http://www.fccnn.com/newspaper.php">randomness</a> -->  </div>
</div><script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.ajax({url:'http://itracking.fccinteractive.com/tracking/drupalcms/insert_impressions.php?domain=republican-eagle.com&tags=Life, arts and entertainment,Arts, Entertainment',type:'GET',dataType:'jsonp',crossDomain:true});
//--><!]]>
</script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/jsr_class.min.js?oy50av"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?oy50av"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_JozVjTMXs55bUfFMpJpqqcKwp4OKeoevi65GD95_4ys.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function(){addthis.init()});
//--><!]]>
</script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_jNw4EtyrzIApV82kEWjNIwPts-FQ67yNMAmIDs7C-NE.js"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?oy50av"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?oy50av"></script>
<script type="text/javascript" src="http://www.republican-eagle.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>

    
        <div id='in-page-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('in-page-ad');
          });
        </script>
        </div>
        <div id='wallpaper-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('wallpaper-ad');
          });
        </script>
        </div>  </body>
</html>
